OberonCore
https://forum.oberoncore.ru/

Ошибка в работе модуля CommTCP
https://forum.oberoncore.ru/viewtopic.php?f=23&t=1286
Страница 1 из 1

Автор:  Пётр Кушнир [ Среда, 24 Декабрь, 2008 18:12 ]
Заголовок сообщения:  Ошибка в работе модуля CommTCP

Я использую модуль CommTCP.
В Windows XP я создавал поток обычным образом, оставляя поле localAdr пустым. И всё работало.
Код:
CommStreams.NewStream('CommTCP', '', '127.0.0.1:5222', newStream, res);

После переезда на Windows Vista данный код стал выдавать в res код ошибки CommStreams.invalidLocalAdr, я почему-то интуитивно присвоил localAdr значение 'localhost'. После этого всё заработало как раньше, и я забыл о проблеме.
Однако на днях потребовалось запустить подсистему в локальной сети, и обнаружилось что с задаными параметрами ББ не может создать новое соединение. Я попробовал то же в ББ 1.6 - результат точно такой же. Обнаружил альтернативный драйвер CommTCPAsync. Поставил, он заработал при localAdr = '', но с ошибками, соединяется с сервером не всегда даже на одном компьютере.
Кто-нибудь сталкивался с подобным?

Автор:  Илья Ермаков [ Четверг, 25 Декабрь, 2008 00:21 ]
Заголовок сообщения:  Re: Ошибка в работе модуля CommTCP

Да, у меня была та же история (Info21 помнит) - разработанную на Вин2к подсистему хотел показать на ноутбуке с вистой. Налетел на эти ошибки, пришлось копировать на машину с Ыкспи. Тогда погрешил на брандмауэр.

Автор:  Пётр Кушнир [ Четверг, 25 Декабрь, 2008 11:46 ]
Заголовок сообщения:  Re: Ошибка в работе модуля CommTCP

Брандмауэр непричём, когда я тестировал - он был выключен на всех компах.
Я тут погуглил, нашёл сообщения о похожих ошибках в Делфи. В похожей ситуации тоже не происходит коннекта.
Ещё, как оказалось, библиотека wsock32.dll на которой основан модуль WinSocket уже давно является только обёрткой и все вызовы в ней перенаправляются в ws2_32.dll

Как всегда мелкософтовцы опять начудили с обратной совместимостью. :(

Автор:  Пётр Кушнир [ Воскресенье, 28 Декабрь, 2008 19:04 ]
Заголовок сообщения:  Re: Ошибка в работе модуля CommTCP

Методом научного тыка нашёл решение: при создании соединения надо указать localAdr = '0.0.0.0:0' тогда соединение создаётся успешно в любой системе(пробовал в XP SP2, XP SP3, Vista, Vista SP1).

Автор:  Евгений Семашко [ Суббота, 24 Январь, 2009 01:09 ]
Заголовок сообщения:  Re: Ошибка в работе модуля CommTCP

Из документации к модулю TCP:
Цитата:
Note: Certain operating systems (e.g. Microsoft Windows Server 2003) do not accept an empty string or just a port number as valid values for localAdr. Use the values "0.0.0.0:0" or "0.0.0.0:<port number>" (e.g. "0.0.0.0:2") instead.

Автор:  sasha-kulov [ Вторник, 15 Май, 2018 00:39 ]
Заголовок сообщения:  Re: Ошибка в работе модуля CommTCP

Друзья, только что удалось разобраться с этой ситуацией

Локальный адрес на клиенте должен быть 0.0.0.0:0,
а на сервере 0.0.0.0:900 или другой порт,
Спасибо, всем особое спасибо за демку с передачей файла.
Да по поводу Брандмауэра, если он включен,то при первом
запуске сервера, он спрашивает разрешение на добавление
этого исключения, и все.

Автор:  sasha-kulov [ Вторник, 15 Май, 2018 00:46 ]
Заголовок сообщения:  Re: Ошибка в работе модуля CommTCP

Демку от Пётр Кушнир
забыл вставить, на всякий случай,
она была в другой ветке. 30 Март, 2009 16:12
Заголовок сообщения: Re: Как сделать аналог Wait?
viewtopic.php?f=23&t=1426&p=26690&hilit=CommTCP#p26689

Вложения:
Mod.zip [4.34 КБ]
Скачиваний: 61

Страница 1 из 1 Часовой пояс: UTC + 3 часа
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/